What’s Vulnerable › Vulnerabilities
CVE-2014-0101
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-03-11 · updated 2026-06-17
- Weakness: CWE-476
Description
The sctp_sf_do_5_1D_ce function in net/sctp/sm_statefuns.c in the Linux kernel through 3.13.6 does not validate certain auth_enable and auth_capable fields before making an sctp_sf_authenticate call, which allows remote attackers to cause a denial of service (NULL pointer dereference and system crash) via an SCTP handshake with a modified INIT chunk and a crafted AUTH chunk before a COOKIE_ECHO chunk.
Affected products
- Canonical Ubuntu Linux: 10.04
- F5 BIG-IP APM: from 11.1.0 through 11.5.3
- BIG-IP: from 11.3.0 through 11.5.3
- F5 Big-Ip Analytics: from 11.1.0 through 11.5.3
- F5 Networks, Inc. BIG-IP (AAM): from 11.4.0 through 11.5.3
- BIG-IP ASM: from 11.1.0 through 11.5.3
- F5 Big-Ip Edge Gateway: from 11.1.0 through 11.3.0
- F5 Networks BIG-IP, Enterprise Manager: from 2.1.0 through 2.3.0; from 3.0.0 through 3.1.1
- F5 Big-Ip Global Traffic Manager: from 11.1.0 through 11.5.3
- F5 Big-Ip Link Controller: from 11.1.0 through 11.5.3
- F5 BIG-IP (LTM): from 11.1.0 through 11.5.3
- F5 Networks, Inc. BIG-IP (PEM): from 11.3.0 through 11.5.3
- F5 Big-Ip Protocol Security Module: from 11.1.0 through 11.4.1
- F5 Big-Ip Wan Optimization Manager: from 11.1.0 through 11.3.0
- F5 Big-Ip Webaccelerator: from 11.1.0 through 11.3.0
- F5 Big-Iq Adc: 4.5.0
- F5 BIG-IQ: 4.6.0
- F5 Big-Iq Cloud: from 4.0.0 through 4.5.0
- F5 Big-Iq Device: from 4.2.0 through 4.5.0
- F5 Big-Iq Security: from 4.0.0 through 4.5.0
- Linux kernel: from 2.6.24 before 3.2.56; from 3.3 before 3.4.84; from 3.5 before 3.10.34; from 3.11 before 3.12.15; from 3.13 before 3.13.7 — fixed in 3.10.34, 3.12.15, 3.13.7, 3.2.56, 3.4.84
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Eus: 6.3, 6.4, 6.5
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Server Aus: 6.4, 6.5
- RedHat Enterprise Linux Server Tus: 6.5
- RedHat Enterprise Linux Workstation: 6.0
How to fix
Upgrade to a fixed version: Linux kernel 3.10.34, 3.12.15, 3.13.7, 3.2.56. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=ec0223ec48a90cb605244b45f7c62de856403729
- http://rhn.redhat.com/errata/RHSA-2014-0328.html
- http://rhn.redhat.com/errata/RHSA-2014-0419.html
- http://rhn.redhat.com/errata/RHSA-2014-0432.html
- http://secunia.com/advisories/59216
- http://support.f5.com/kb/en-us/solutions/public/15000/300/sol15317.html
- http://www.openwall.com/lists/oss-security/2014/03/04/6
- http://www.securityfocus.com/bid/65943
- http://www.ubuntu.com/usn/USN-2173-1
- http://www.ubuntu.com/usn/USN-2174-1
- https://bugzilla.redhat.com/show_bug.cgi?id=1070705
- https://github.com/torvalds/linux/commit/ec0223ec48a90cb605244b45f7c62de856403729
Get alerted when CVE-2014-0101 or the next vulnerability affects your stack