What’s Vulnerable › Vulnerabilities
CVE-2014-0104
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-02 · updated 2026-06-17
- Weakness: CWE-295
Description
In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.
Affected products
- fence-agents: before 4.0.17 — fixed in 4.0.17
How to fix
Upgrade to a fixed version: fence-agents 4.0.17. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/cve-2014-0104
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-0104
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2014-0104
- https://security-tracker.debian.org/tracker/CVE-2014-0104
- https://access.redhat.com/security/cve/cve-2014-0104
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-0104
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2014-0104
- https://security-tracker.debian.org/tracker/CVE-2014-0104
Get alerted when CVE-2014-0104 or the next vulnerability affects your stack