What’s Vulnerable › Vulnerabilities
CVE-2014-0111
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-04-17 · updated 2026-06-17
- Weakness: CWE-94
Description
Apache Syncope 1.0.0 before 1.0.9 and 1.1.0 before 1.1.7 allows remote administrators to execute arbitrary Java code via vectors related to Apache Commons JEXL expressions, "derived schema definition," "user / role templates," and "account links of resource mappings."
Affected products
- Apache Software Foundation Apache Syncope: from 1.0.0 before 1.0.9; from 1.1.0 before 1.1.7 — fixed in 1.0.9, 1.1.7
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Syncope 1.0.9, 1.1.7. Check the vendor advisory for mitigations.
References
- http://mail-archives.us.apache.org/mod_mbox/www-announce/201404.mbox/%3C534CE273.9020601%40apache.org%3E
- http://syncope.apache.org/security.html
- http://www.securityfocus.com/archive/1/531841/100/0/threaded
- http://mail-archives.us.apache.org/mod_mbox/www-announce/201404.mbox/%3C534CE273.9020601%40apache.org%3E
- http://syncope.apache.org/security.html
- http://www.securityfocus.com/archive/1/531841/100/0/threaded
Get alerted when CVE-2014-0111 or the next vulnerability affects your stack