What’s Vulnerable › Vulnerabilities
CVE-2014-0112
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 98.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-04-29 · updated 2026-06-17
- Weakness: CWE-264
Description
ParametersInterceptor in Apache Struts before 2.3.20 does not properly restrict access to the getClass method, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via a crafted request. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-0094.
Affected products
- Apache Struts: from 2.0.0 before 2.3.16.2 — fixed in 2.3.16.2
How to fix
Upgrade to a fixed version: Apache Struts 2.3.16.2. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN19294237/index.html
- http://jvndb.jvn.jp/jvndb/JVNDB-2014-000045
- http://packetstormsecurity.com/files/127215/VMware-Security-Advisory-2014-0007.html
- http://secunia.com/advisories/59178
- http://secunia.com/advisories/59500
- http://www-01.ibm.com/support/docview.wss?uid=swg21676706
- http://www.oracle.com/technetwork/topics/security/cpuapr2015-2365600.html
- http://www.securityfocus.com/archive/1/531952/100/0/threaded
- http://www.securityfocus.com/archive/1/532549/100/0/threaded
- http://www.securityfocus.com/bid/67064
- http://www.vmware.com/security/advisories/VMSA-2014-0007.html
- https://access.redhat.com/errata/RHSA-2019:0910
Get alerted when CVE-2014-0112 or the next vulnerability affects your stack