What’s Vulnerable › Vulnerabilities
CVE-2014-0130: Ruby on Rails Directory Traversal Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-25
- EPSS: 53.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-05-07 · updated 2026-06-17
- Weakness: CWE-22
Description
Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the implicit-render implementation in Ruby on Rails before 3.2.18, 4.0.x before 4.0.5, and 4.1.x before 4.1.1, when certain route globbing configurations are enabled, allows remote attackers to read arbitrary files via a crafted request.
Affected products
- RedHat Enterprise Linux Server: 6.0
- RedHat Subscription Asset Manager: through 1.3.0
- Ruby on Rails: before 3.2.18; from 4.0.0 before 4.0.5; from 4.1.0 before 4.1.1 — fixed in 3.2.18, 4.0.5, 4.1.1
How to fix
Upgrade to a fixed version: Ruby on Rails 3.2.18, 4.0.5, 4.1.1. Check the vendor advisory for mitigations.
References
- http://matasano.com/research/AnatomyOfRailsVuln-CVE-2014-0130.pdf
- http://rhn.redhat.com/errata/RHSA-2014-1863.html
- http://www.securityfocus.com/bid/67244
- https://groups.google.com/forum/message/raw?msg=rubyonrails-security/NkKc7vTW70o/NxW_PDBSG3AJ
- http://matasano.com/research/AnatomyOfRailsVuln-CVE-2014-0130.pdf
- http://rhn.redhat.com/errata/RHSA-2014-1863.html
- http://www.securityfocus.com/bid/67244
- https://groups.google.com/forum/message/raw?msg=rubyonrails-security/NkKc7vTW70o/NxW_PDBSG3AJ
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2014-0130
Get alerted when CVE-2014-0130 or the next vulnerability affects your stack