What’s Vulnerable › Vulnerabilities
CVE-2014-0147
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-29 · updated 2026-06-17
- Weakness: CWE-190
Description
Qemu before 1.6.2 block diver for the various disk image formats used by Bochs and for the QCOW version 2 format, are vulnerable to a possible crash caused by signed data types or a logic error while creating QCOW2 snapshots, which leads to incorrectly calling update_refcount() routine.
Affected products
- Fedoraproject Fedora: 20
- QEMU: before 1.6.2 — fixed in 1.6.2
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Eus: 6.5
- RedHat Enterprise Linux Openstack Platform: 5
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Server Aus: 6.5
- RedHat Enterprise Linux Server Tus: 6.5
- RedHat Enterprise Linux Workstation: 6.0
- RedHat Virtualization: 3.0
How to fix
Upgrade to a fixed version: QEMU 1.6.2. Check the vendor advisory for mitigations.
References
- http://git.qemu.org/?p=qemu.git%3Ba=commitdiff%3Bh=246f65838d19db6db55bfb41117c35645a2c4789
- http://rhn.redhat.com/errata/RHSA-2014-0420.html
- http://rhn.redhat.com/errata/RHSA-2014-0421.html
- http://www.openwall.com/lists/oss-security/2014/03/26/8
- https://bugzilla.redhat.com/show_bug.cgi?id=1078848
- https://bugzilla.redhat.com/show_bug.cgi?id=1086717
- http://git.qemu.org/?p=qemu.git%3Ba=commitdiff%3Bh=246f65838d19db6db55bfb41117c35645a2c4789
- http://rhn.redhat.com/errata/RHSA-2014-0420.html
- http://rhn.redhat.com/errata/RHSA-2014-0421.html
- http://www.openwall.com/lists/oss-security/2014/03/26/8
- https://bugzilla.redhat.com/show_bug.cgi?id=1078848
- https://bugzilla.redhat.com/show_bug.cgi?id=1086717
Get alerted when CVE-2014-0147 or the next vulnerability affects your stack