What’s Vulnerable › Vulnerabilities
CVE-2014-0148
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-29 · updated 2026-06-17
- Weakness: CWE-835
Description
Qemu before 2.0 block driver for Hyper-V VHDX Images is vulnerable to infinite loops and other potential issues when calculating BAT entries, due to missing bounds checks for block_size and logical_sector_size variables. These are used to derive other fields like 'sectors_per_block' etc. A user able to alter the Qemu disk image could ise this flaw to crash the Qemu instance resulting in DoS.
Affected products
- QEMU: before 2.0.0 — fixed in 2.0.0
- RedHat Enterprise Linux Desktop: 6.0
- RedHat Enterprise Linux Eus: 6.5
- RedHat Enterprise Linux Openstack Platform: 5
- RedHat Enterprise Linux Server: 6.0
- RedHat Enterprise Linux Server Aus: 6.5
- RedHat Enterprise Linux Server Tus: 6.5
- RedHat Enterprise Linux Workstation: 6.0
- RedHat Virtualization: 3.0
How to fix
Upgrade to a fixed version: QEMU 2.0.0. Check the vendor advisory for mitigations.
References
- http://git.qemu.org/?p=qemu.git%3Ba=commit%3Bh=1d7678dec4761acdc43439da6ceda41a703ba1a6
- http://rhn.redhat.com/errata/RHSA-2014-0420.html
- http://rhn.redhat.com/errata/RHSA-2014-0421.html
- http://www.openwall.com/lists/oss-security/2014/03/26/8
- https://bugzilla.redhat.com/show_bug.cgi?id=1078212
- https://lists.gnu.org/archive/html/qemu-devel/2014-03/msg04994.html
- http://git.qemu.org/?p=qemu.git%3Ba=commit%3Bh=1d7678dec4761acdc43439da6ceda41a703ba1a6
- http://rhn.redhat.com/errata/RHSA-2014-0420.html
- http://rhn.redhat.com/errata/RHSA-2014-0421.html
- http://www.openwall.com/lists/oss-security/2014/03/26/8
- https://bugzilla.redhat.com/show_bug.cgi?id=1078212
- https://lists.gnu.org/archive/html/qemu-devel/2014-03/msg04994.html
Get alerted when CVE-2014-0148 or the next vulnerability affects your stack