What’s Vulnerable › Vulnerabilities

CVE-2014-0160: OpenSSL Information Disclosure Vulnerability

Description

The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly handle Heartbeat Extension packets, which allows remote attackers to obtain sensitive information from process memory via crafted packets that trigger a buffer over-read, as demonstrated by reading private keys, related to d1_both.c and t1_lib.c, aka the Heartbleed bug.

Affected products

How to fix

Upgrade to a fixed version: FileZilla Server 0.9.44; OpenSSL 1.0.1g; Siemens Elan-8.2 8.3.3; Splunk Enterprise 6.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-0160 or the next vulnerability affects your stack