What’s Vulnerable › Vulnerabilities
CVE-2014-0185
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-05-06 · updated 2026-06-17
- Weakness: CWE-269
Description
sapi/fpm/fpm/fpm_unix.c in the FastCGI Process Manager (FPM) in PHP before 5.4.28 and 5.5.x before 5.5.12 uses 0666 permissions for the UNIX socket, which allows local users to gain privileges via a crafted FastCGI client.
Affected products
- PHP: from 5.3.0 before 5.3.28; from 5.4.0 before 5.4.28; from 5.5.0 before 5.5.12 — fixed in 5.3.28, 5.4.28, 5.5.12
How to fix
Upgrade to a fixed version: PHP 5.3.28, 5.4.28, 5.5.12. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00012.html
- http://secunia.com/advisories/59061
- http://secunia.com/advisories/59329
- http://support.apple.com/kb/HT6443
- http://www.openwall.com/lists/oss-security/2014/04/29/5
- http://www.php.net/ChangeLog-5.php
- http://www.php.net/archive/2014.php#id2014-05-01-1
- https://bugs.launchpad.net/ubuntu/+source/php5/+bug/1307027
- https://bugs.php.net/bug.php?id=67060
- https://bugzilla.redhat.com/show_bug.cgi?id=1092815
- https://github.com/php/php-src/commit/35ceea928b12373a3b1e3eecdc32ed323223a40d
- https://hoffmann-christian.info/files/php-fpm/0001-Fix-bug-67060-use-default-mode-of-660.patch
Get alerted when CVE-2014-0185 or the next vulnerability affects your stack