What’s Vulnerable › Vulnerabilities
CVE-2014-0196: Linux Kernel Race Condition Vulnerability
- Severity: medium (CVSS 6.9 v2.0)
- Exploited in the wild: yes — in CISA KEV since 2023-05-12
- EPSS: 20.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-05-07 · updated 2026-06-17
- Weakness: CWE-362
Description
The n_tty_write function in drivers/tty/n_tty.c in the Linux kernel through 3.14.3 does not properly manage tty driver access in the "LECHO & !OPOST" case, which allows local users to cause a denial of service (memory corruption and system crash) or gain privileges by triggering a race condition involving read and write operations with long strings.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10, 13.10, 14.04
- Debian Linux: 6.0, 7.0
- F5 BIG-IP APM: from 11.1.0 through 11.5.1
- BIG-IP: from 11.3.0 through 11.5.1
- F5 Big-Ip Analytics: from 11.1.0 through 11.5.1
- F5 Networks, Inc. BIG-IP (AAM): from 11.4.0 through 11.5.1
- BIG-IP ASM: from 11.1.0 through 11.5.1
- F5 Big-Ip Edge Gateway: from 11.1.0 through 11.3.0
- F5 Big-Ip Global Traffic Manager: from 11.1.0 through 11.5.1
- F5 Big-Ip Link Controller: from 11.1.0 through 11.5.1
- F5 BIG-IP (LTM): from 11.1.0 through 11.5.1
- F5 Networks, Inc. BIG-IP (PEM): from 11.3.0 through 11.5.1
- F5 Big-Ip Protocol Security Module: from 11.1.0 through 11.4.1
- F5 Big-Ip Wan Optimization Manager: from 11.1.0 through 11.3.0
- F5 Big-Ip Webaccelerator: from 11.1.0 through 11.3.0
- F5 Big-Iq Application Delivery Controller: 4.5.0
- F5 BIG-IQ: 4.6.0
- F5 Big-Iq Cloud: from 4.0.0 through 4.5.0
- F5 Networks, Inc. BIG-IQ Cloud and Orchestration: 1.0.0
- F5 Big-Iq Device: from 4.2.0 through 4.5.0
- F5 Big-Iq Security: from 4.0.0 through 4.5.0
- F5 Networks, Inc. Enterprise Manager: 3.1.0, 3.1.1
- Linux kernel: from 2.6.31 (excl.) before 3.2.59; from 3.3 before 3.4.91; from 3.5 before 3.10.40; from 3.11 before 3.12.20; from 3.13 before 3.14.4; 2.6.31, 2.6.31-rc3, 2.6.31-rc4, 2.6.31-rc5, 2.6.31-rc6, 2.6.31-rc7 (+2) — fixed in 3.10.40, 3.12.20, 3.14.4, 3.2.59, 3.4.91
- Oracle Corporation Oracle Linux: 6
- Red Hat Enterprise Linux: 6.0
- RedHat Enterprise Linux Eus: 6.3, 6.4
- RedHat Enterprise Linux Server Eus: 6.3
- Suse Linux Enterprise Desktop: 11-sp3
- Suse Linux Enterprise High Availability Extension: 11-sp3
- SUSE Linux Enterprise: 11-sp3
How to fix
Upgrade to a fixed version: Linux kernel 3.10.40, 3.12.20, 3.14.4, 3.2.59. Check the vendor advisory for mitigations.
References
- http://bugzilla.novell.com/show_bug.cgi?id=875690
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=4291086b1f081b869c6d79e5b7441633dc3ace00
- http://linux.oracle.com/errata/ELSA-2014-0771.html
- http://lists.opensuse.org/opensuse-security-announce/2014-05/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2014-05/msg00012.html
- http://pastebin.com/raw.php?i=yTSFUBgZ
- http://rhn.redhat.com/errata/RHSA-2014-0512.html
- http://secunia.com/advisories/59218
- http://secunia.com/advisories/59262
- http://secunia.com/advisories/59599
- http://source.android.com/security/bulletin/2016-07-01.html
- http://support.f5.com/kb/en-us/solutions/public/15000/300/sol15319.html
Get alerted when CVE-2014-0196 or the next vulnerability affects your stack