What’s Vulnerable › Vulnerabilities
CVE-2014-0198
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 40.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-05-06 · updated 2026-06-17
- Weakness: CWE-476
Description
The do_ssl3_write function in s3_pkt.c in OpenSSL 1.x through 1.0.1g, when SSL_MODE_RELEASE_BUFFERS is enabled, does not properly manage a buffer pointer during certain recursive calls, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via vectors that trigger an alert condition.
Affected products
- Debian Linux: 6.0, 7.0, 8.0
- Fedoraproject Fedora: 19, 20
- MariaDB: from 10.0.0 before 10.0.13 — fixed in 10.0.13
- OpenSSL: from 1.0.0 through 1.0.1g
- Opensuse: 12.3, 13.1
- SUSE Linux Enterprise Server 15 SP1: 12
- SUSE Linux Enterprise Server: 12
- SUSE Linux Enterprise Software Development Kit: 12
- SUSE Linux Enterprise Workstation Extension: 12
How to fix
Upgrade to a fixed version: MariaDB 10.0.13. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2014-0204.html
- http://aix.software.ibm.com/aix/efixes/security/openssl_advisory9.asc
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10629
- http://kb.juniper.net/InfoCenter/index?page=content&id=KB29195
- http://lists.fedoraproject.org/pipermail/package-announce/2014-August/136470.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-August/136473.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00016.html
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00036.html
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00037.html
- http://marc.info/?l=bugtraq&m=140389274407904&w=2
- http://marc.info/?l=bugtraq&m=140389355508263&w=2
- http://marc.info/?l=bugtraq&m=140431828824371&w=2
Get alerted when CVE-2014-0198 or the next vulnerability affects your stack