What’s Vulnerable › Vulnerabilities

CVE-2014-0224

Description

OpenSSL before 0.9.8za, 1.0.0 before 1.0.0m, and 1.0.1 before 1.0.1h does not properly restrict processing of ChangeCipherSpec messages, which allows man-in-the-middle attackers to trigger use of a zero-length master key in certain OpenSSL-to-OpenSSL communications, and consequently hijack sessions or obtain sensitive information, via a crafted TLS handshake, aka the "CCS Injection" vulnerability.

Affected products

How to fix

Upgrade to a fixed version: FileZilla Server 0.9.45; MariaDB 10.0.13; Node.js 0.10.29; OpenSSL 0.9.8za, 1.0.0m, 1.0.1h; Python 2.7.8, 3.4.2; Siemens Application Processing Engine Firmware 2.0.2; Siemens Cp1543-1 Firmware 1.1.25; Siemens Rox Firmware 1.16.1; Siemens S7-1500 Firmware 1.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-0224 or the next vulnerability affects your stack