What’s Vulnerable › Vulnerabilities
CVE-2014-0226
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 85.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-07-20 · updated 2026-06-17
- Weakness: CWE-362
Description
Race condition in the mod_status module in the Apache HTTP Server before 2.4.10 allows remote attackers to cause a denial of service (heap-based buffer overflow), or possibly obtain sensitive credential information or execute arbitrary code, via a crafted request that triggers improper scoreboard handling within the status_handler function in modules/generators/mod_status.c and the lua_ap_scoreboard_worker function in modules/lua/lua_request.c.
Affected products
- Apache HTTP Server: from 2.2.0 before 2.2.29; from 2.4.1 before 2.4.10 — fixed in 2.2.29, 2.4.10
- Debian Linux: 7.0, 8.0
- Oracle Corporation Enterprise Manager Ops Center: 11.1.3, 12.1.4
- Oracle Corporation Oracle HTTP Server: 10.1.3.5.0, 11.1.1.7.0, 12.1.2.0, 12.1.3.0
- Oracle Corporation Secure Global Desktop: 4.63, 4.71, 5.0, 5.1
- Red Hat JBoss EAP: 6.0.0, 6.4.0
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.2.29, 2.4.10. Check the vendor advisory for mitigations.
References
- http://advisories.mageia.org/MGASA-2014-0304.html
- http://advisories.mageia.org/MGASA-2014-0305.html
- http://httpd.apache.org/security/vulnerabilities_24.html
- http://lists.apple.com/archives/security-announce/2015/Apr/msg00001.html
- http://marc.info/?l=bugtraq&m=143403519711434&w=2
- http://marc.info/?l=bugtraq&m=143748090628601&w=2
- http://marc.info/?l=bugtraq&m=144050155601375&w=2
- http://marc.info/?l=bugtraq&m=144493176821532&w=2
- http://rhn.redhat.com/errata/RHSA-2014-1019.html
- http://rhn.redhat.com/errata/RHSA-2014-1020.html
- http://rhn.redhat.com/errata/RHSA-2014-1021.html
- http://seclists.org/fulldisclosure/2014/Jul/114
Get alerted when CVE-2014-0226 or the next vulnerability affects your stack