What’s Vulnerable › Vulnerabilities
CVE-2014-0237
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-06-01 · updated 2026-06-17
- Weakness: CWE-399
Description
The cdf_unpack_summary_info function in cdf.c in the Fileinfo component in PHP before 5.4.29 and 5.5.x before 5.5.13 allows remote attackers to cause a denial of service (performance degradation) by triggering many file_printf calls.
Affected products
- Debian Linux: 7.0, 8.0
- PHP: before 5.3.29; from 5.4.0 before 5.4.29; from 5.5.0 before 5.5.13 — fixed in 5.3.29, 5.4.29, 5.5.13
How to fix
Upgrade to a fixed version: PHP 5.3.29, 5.4.29, 5.5.13. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2015/Apr/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2014-07/msg00002.html
- http://rhn.redhat.com/errata/RHSA-2014-1765.html
- http://rhn.redhat.com/errata/RHSA-2014-1766.html
- http://secunia.com/advisories/59061
- http://secunia.com/advisories/59329
- http://secunia.com/advisories/59418
- http://secunia.com/advisories/60998
- http://support.apple.com/kb/HT6443
- http://www-01.ibm.com/support/docview.wss?uid=swg21683486
- http://www.debian.org/security/2014/dsa-3021
- http://www.oracle.com/technetwork/topics/security/bulletinjan2015-2370101.html
Get alerted when CVE-2014-0237 or the next vulnerability affects your stack