What’s Vulnerable › Vulnerabilities
CVE-2014-0456
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-04-16 · updated 2026-06-17
Description
Unspecified vulnerability in Oracle Java SE 6u71, 7u51, and 8, and Java SE Embedded 7u51, allows remote attackers to affect confidentiality, integrity, and availability via unknown vectors related to Hotspot.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10, 13.10, 14.04
- Debian Linux: 6.0, 7.0, 8.0
- IBM Forms Viewer: from 4.0.0 before 4.0.0.3; from 8.0.0 before 8.0.1.1 — fixed in 4.0.0.3, 8.0.1.1
- Juniper Networks Junos Space: before 15.1 — fixed in 15.1
- Oracle Java SE: 1.5.0-update61, 1.6.0-update71, 1.7.0-update51, 1.8.0
- Oracle Java SE: 1.5.0-update61, 1.6.0-update71, 1.7.0-update51, 1.8.0
- Oracle JRockit: r27.8.1, r28.3.1
How to fix
Upgrade to a fixed version: IBM Forms Viewer 4.0.0.3, 8.0.1.1; Juniper Networks Junos Space 15.1. Check the vendor advisory for mitigations.
References
- http://kb.juniper.net/InfoCenter/index?page=content&id=JSA10698
- http://marc.info/?l=bugtraq&m=140852886808946&w=2
- http://marc.info/?l=bugtraq&m=140852974709252&w=2
- http://rhn.redhat.com/errata/RHSA-2014-0675.html
- http://rhn.redhat.com/errata/RHSA-2014-0685.html
- http://secunia.com/advisories/58415
- http://security.gentoo.org/glsa/glsa-201406-32.xml
- http://security.gentoo.org/glsa/glsa-201502-12.xml
- http://www.debian.org/security/2014/dsa-2912
- http://www.oracle.com/technetwork/topics/security/cpuapr2014-1972952.html
- http://www.securityfocus.com/bid/66877
- http://www.ubuntu.com/usn/USN-2187-1
Get alerted when CVE-2014-0456 or the next vulnerability affects your stack