What’s Vulnerable › Vulnerabilities
CVE-2014-0593: sed command injection
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-08 · updated 2026-06-17
- Weakness: CWE-78
Description
The set_version script as shipped with obs-service-set_version is a source validator for the Open Build Service (OBS). In versions prior to 0.5.3-1.1 this script did not properly sanitize the input provided by the user, allowing for code execution on the executing server.
Affected products
- openSUSE Open Build Service: from 0.5.3 before 1.1 — fixed in 1.1
How to fix
Upgrade to a fixed version: openSUSE Open Build Service 1.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=866966
- https://github.com/openSUSE/obs-service-set_version/commit/10d5bddcea29f74a175f7f550924bf6407e52e93
- https://lists.opensuse.org/opensuse-buildservice/2014-03/msg00014.html
- https://www.suse.com/de-de/security/cve/CVE-2014-0593/
- https://bugzilla.suse.com/show_bug.cgi?id=866966
- https://github.com/openSUSE/obs-service-set_version/commit/10d5bddcea29f74a175f7f550924bf6407e52e93
- https://lists.opensuse.org/opensuse-buildservice/2014-03/msg00014.html
- https://www.suse.com/de-de/security/cve/CVE-2014-0593/
Get alerted when CVE-2014-0593 or the next vulnerability affects your stack