What’s Vulnerable › Vulnerabilities
CVE-2014-10066
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-22
Description
Versions less than 0.1.4 of the static file server module fancy-server are vulnerable to directory traversal. An attacker can provide input such as `../` to read files outside of the served directory.
Affected products
- HackerOne fancy-server node module: before 0.1.4 — fixed in 0.1.4
How to fix
Upgrade to a fixed version: HackerOne fancy-server node module 0.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2014-10066 or the next vulnerability affects your stack