What’s Vulnerable › Vulnerabilities
CVE-2014-10067
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-29 · updated 2026-06-17
- Weakness: CWE-287
Description
paypal-ipn before 3.0.0 uses the `test_ipn` parameter (which is set by the PayPal IPN simulator) to determine if it should use the production PayPal site or the sandbox. With a bit of time, an attacker could craft a request using the simulator that would fool any application which does not explicitly check for test_ipn in production.
Affected products
- HackerOne paypal-ipn node module: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: HackerOne paypal-ipn node module 3.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/andzdroid/paypal-ipn/issues/11
- https://nodesecurity.io/advisories/26
- https://github.com/andzdroid/paypal-ipn/issues/11
- https://nodesecurity.io/advisories/26
Get alerted when CVE-2014-10067 or the next vulnerability affects your stack