What’s Vulnerable › Vulnerabilities
CVE-2014-10071
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-27 · updated 2026-06-17
- Weakness: CWE-119
Description
In exec.c in zsh before 5.0.7, there is a buffer overflow for very long fds in the ">& fd" syntax.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- zsh: before 5.0.7 — fixed in 5.0.7
How to fix
Upgrade to a fixed version: zsh 5.0.7. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:3073
- https://sourceforge.net/p/zsh/code/ci/49a3086bb67575435251c70ee598e2fd406ef055
- https://usn.ubuntu.com/3593-1/
- https://access.redhat.com/errata/RHSA-2018:3073
- https://sourceforge.net/p/zsh/code/ci/49a3086bb67575435251c70ee598e2fd406ef055
- https://usn.ubuntu.com/3593-1/
Get alerted when CVE-2014-10071 or the next vulnerability affects your stack