What’s Vulnerable › Vulnerabilities
CVE-2014-10077
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-06 · updated 2026-06-17
- Weakness: CWE-20
Description
Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.
Affected products
- Debian Linux: 8.0
- i18n: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: i18n 0.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/rubysec/ruby-advisory-db/pull/182/files
- https://github.com/svenfuchs/i18n/pull/289
- https://github.com/svenfuchs/i18n/releases/tag/v0.8.0
- https://lists.debian.org/debian-lts-announce/2018/11/msg00021.html
- https://github.com/rubysec/ruby-advisory-db/pull/182/files
- https://github.com/svenfuchs/i18n/pull/289
- https://github.com/svenfuchs/i18n/releases/tag/v0.8.0
- https://lists.debian.org/debian-lts-announce/2018/11/msg00021.html
Get alerted when CVE-2014-10077 or the next vulnerability affects your stack