What’s Vulnerable › Vulnerabilities
CVE-2014-10375
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-14 · updated 2026-06-17
- Weakness: CWE-189
Description
handle_messages in eXtl_tls.c in eXosip before 5.0.0 mishandles a negative value in a content-length header.
Affected products
- GNU Exosip: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: GNU Exosip 5.0.0. Check the vendor advisory for mitigations.
References
- http://git.savannah.nongnu.org/cgit/exosip.git/commit/?id=2549e421c14aff886629b8482c14af800f411070
- http://git.savannah.nongnu.org/cgit/exosip.git/commit/?id=2549e421c14aff886629b8482c14af800f411070
Get alerted when CVE-2014-10375 or the next vulnerability affects your stack