What’s Vulnerable › Vulnerabilities
CVE-2014-125029: ttskch PaginationServiceProvider Demo index.php sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-07 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability was found in ttskch PaginationServiceProvider up to 0.x. It has been declared as critical. This vulnerability affects unknown code of the file demo/index.php of the component demo. The manipulation of the argument sort/id leads to sql injection. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as 619de478efce17ece1a3b913ab16e40651e1ea7b. It is recommended to upgrade the affected component. VDB-217150 is the identifier assigned to this vulnerability.
Affected products
- ttskch PaginationServiceProvider: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: ttskch PaginationServiceProvider 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/ttskch/PaginationServiceProvider/commit/619de478efce17ece1a3b913ab16e40651e1ea7b
- https://github.com/ttskch/PaginationServiceProvider/releases/tag/1.0.0
- https://vuldb.com/?ctiid.217150
- https://vuldb.com/?id.217150
- https://github.com/ttskch/PaginationServiceProvider/commit/619de478efce17ece1a3b913ab16e40651e1ea7b
- https://github.com/ttskch/PaginationServiceProvider/releases/tag/1.0.0
- https://vuldb.com/?ctiid.217150
- https://vuldb.com/?id.217150
Get alerted when CVE-2014-125029 or the next vulnerability affects your stack