What’s Vulnerable › Vulnerabilities
CVE-2014-125044: soshtolsus wing-tight index.php file inclusion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-05 · updated 2026-06-17
- Weakness: CWE-73
Description
A vulnerability, which was classified as critical, was found in soshtolsus wing-tight. This affects an unknown part of the file index.php. The manipulation of the argument p leads to file inclusion. It is possible to initiate the attack remotely. Upgrading to version 1.0.0 is able to address this issue. The patch is named 567bc33e6ed82b0d0179c9add707ac2b257aeaf2. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217515.
Affected products
- soshtolsus wing-tight: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: soshtolsus wing-tight 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/soshtolsus/wing-tight/commit/567bc33e6ed82b0d0179c9add707ac2b257aeaf2
- https://github.com/soshtolsus/wing-tight/releases/tag/1.0.0
- https://vuldb.com/?ctiid.217515
- https://vuldb.com/?id.217515
- https://github.com/soshtolsus/wing-tight/commit/567bc33e6ed82b0d0179c9add707ac2b257aeaf2
- https://github.com/soshtolsus/wing-tight/releases/tag/1.0.0
- https://vuldb.com/?ctiid.217515
- https://vuldb.com/?id.217515
Get alerted when CVE-2014-125044 or the next vulnerability affects your stack