What’s Vulnerable › Vulnerabilities
CVE-2014-125051: himiklab yii2-jqgrid-widget JqGridAction.php addSearchOptionsRecursively sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-06 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function addSearchOptionsRecursively of the file JqGridAction.php. The manipulation leads to sql injection. Upgrading to version 1.0.8 is able to address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.
Affected products
- himiklab yii2-jqgrid-widget: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: himiklab yii2-jqgrid-widget 1.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/himiklab/yii2-jqgrid-widget/commit/a117e0f2df729e3ff726968794d9a5ac40e660b9
- https://github.com/himiklab/yii2-jqgrid-widget/releases/tag/1.0.8
- https://vuldb.com/?ctiid.217564
- https://vuldb.com/?id.217564
- https://github.com/himiklab/yii2-jqgrid-widget/commit/a117e0f2df729e3ff726968794d9a5ac40e660b9
- https://github.com/himiklab/yii2-jqgrid-widget/releases/tag/1.0.8
- https://vuldb.com/?ctiid.217564
- https://vuldb.com/?id.217564
Get alerted when CVE-2014-125051 or the next vulnerability affects your stack