What’s Vulnerable › Vulnerabilities
CVE-2014-125055: agnivade easy-scrypt scrypt.go VerifyPassphrase timing discrepancy
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-07 · updated 2026-06-17
- Weakness: CWE-208
Description
A vulnerability, which was classified as problematic, was found in agnivade easy-scrypt. Affected is the function VerifyPassphrase of the file scrypt.go. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.0.0 is able to address this issue. The name of the patch is 477c10cf3b144ddf96526aa09f5fdea613f21812. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217596.
Affected products
- agnivade easy-scrypt: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: agnivade easy-scrypt 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/agnivade/easy-scrypt/commit/477c10cf3b144ddf96526aa09f5fdea613f21812
- https://github.com/agnivade/easy-scrypt/releases/tag/v1.0.0
- https://vuldb.com/?ctiid.217596
- https://vuldb.com/?id.217596
- https://github.com/agnivade/easy-scrypt/commit/477c10cf3b144ddf96526aa09f5fdea613f21812
- https://github.com/agnivade/easy-scrypt/releases/tag/v1.0.0
- https://vuldb.com/?ctiid.217596
- https://vuldb.com/?id.217596
Get alerted when CVE-2014-125055 or the next vulnerability affects your stack