What’s Vulnerable › Vulnerabilities
CVE-2014-125079: agy pontifex.http Http.coffee sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-15 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability was found in agy pontifex.http. It has been declared as critical. This vulnerability affects unknown code of the file lib/Http.coffee. The manipulation leads to sql injection. Upgrading to version 0.1.0 is able to address this issue. The name of the patch is e52a758f96861dcef2dabfecb9da191bb2e07761. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218356.
Affected products
- agy pontifex.http: before 0.1.0 — fixed in 0.1.0
How to fix
Upgrade to a fixed version: agy pontifex.http 0.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/agy/pontifex.http/commit/e52a758f96861dcef2dabfecb9da191bb2e07761
- https://github.com/agy/pontifex.http/releases/tag/v0.1.0
- https://vuldb.com/?ctiid.218356
- https://vuldb.com/?id.218356
- https://github.com/agy/pontifex.http/commit/e52a758f96861dcef2dabfecb9da191bb2e07761
- https://github.com/agy/pontifex.http/releases/tag/v0.1.0
- https://vuldb.com/?ctiid.218356
- https://vuldb.com/?id.218356
Get alerted when CVE-2014-125079 or the next vulnerability affects your stack