What’s Vulnerable › Vulnerabilities
CVE-2014-125092: MaxButtons Plugin maxbuttons-button.php maxbuttons_strip_px cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in MaxButtons Plugin up to 1.26.0 on WordPress and classified as problematic. This issue affects the function maxbuttons_strip_px of the file includes/maxbuttons-button.php. The manipulation of the argument button_id leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.26.1 is able to address this issue. The patch is named e74564c9e3b7429808e317f4916bd1c26ef0b806. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222323.
Affected products
- maxfoundry MaxButtons – Create buttons: before 1.26.1 — fixed in 1.26.1
How to fix
Upgrade to a fixed version: maxfoundry MaxButtons – Create buttons 1.26.1. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/maxbuttons/commit/e74564c9e3b7429808e317f4916bd1c26ef0b806
- https://github.com/wp-plugins/maxbuttons/releases/tag/1.26.1
- https://vuldb.com/?ctiid.222323
- https://vuldb.com/?id.222323
- https://github.com/wp-plugins/maxbuttons/commit/e74564c9e3b7429808e317f4916bd1c26ef0b806
- https://github.com/wp-plugins/maxbuttons/releases/tag/1.26.1
- https://vuldb.com/?ctiid.222323
- https://vuldb.com/?id.222323
Get alerted when CVE-2014-125092 or the next vulnerability affects your stack