What’s Vulnerable › Vulnerabilities
CVE-2014-125098: Dart http_server Directory Listing virtual_directory.dart VirtualDirectory cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-10 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in Dart http_server up to 0.9.5 and classified as problematic. Affected by this issue is the function VirtualDirectory of the file lib/src/virtual_directory.dart of the component Directory Listing Handler. The manipulation of the argument request.uri.path leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.9.6 is able to address this issue. The name of the patch is 27c1cbd8125bb0369e675eb72e48218496e48ffb. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225356.
Affected products
- Dart http_server: before 0.9.6 — fixed in 0.9.6
How to fix
Upgrade to a fixed version: Dart http_server 0.9.6. Check the vendor advisory for mitigations.
References
- https://codereview.chromium.org/225813002
- https://github.com/dart-archive/http_server/commit/27c1cbd8125bb0369e675eb72e48218496e48ffb
- https://github.com/dart-archive/http_server/releases/tag/0.9.6
- https://vuldb.com/?ctiid.225356
- https://vuldb.com/?id.225356
- https://codereview.chromium.org/225813002
- https://github.com/dart-archive/http_server/commit/27c1cbd8125bb0369e675eb72e48218496e48ffb
- https://github.com/dart-archive/http_server/releases/tag/0.9.6
- https://vuldb.com/?ctiid.225356
- https://vuldb.com/?id.225356
Get alerted when CVE-2014-125098 or the next vulnerability affects your stack