What’s Vulnerable › Vulnerabilities
CVE-2014-125106
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-17 · updated 2026-06-17
- Weakness: CWE-787
Description
Nanopb before 0.3.1 allows size_t overflows in pb_dec_bytes and pb_dec_string.
Affected products
- nanopb: before 0.3.1 — fixed in 0.3.1
How to fix
Upgrade to a fixed version: nanopb 0.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/nanopb/nanopb/blob/master/CHANGELOG.txt
- https://github.com/nanopb/nanopb/commit/d2099cc8f1adb33d427a44a5e32ed27b647c7168
- https://github.com/nanopb/nanopb/compare/nanopb-0.3.0...nanopb-0.3.1
- https://github.com/nanopb/nanopb/blob/master/CHANGELOG.txt
- https://github.com/nanopb/nanopb/commit/d2099cc8f1adb33d427a44a5e32ed27b647c7168
- https://github.com/nanopb/nanopb/compare/nanopb-0.3.0...nanopb-0.3.1
Get alerted when CVE-2014-125106 or the next vulnerability affects your stack