What’s Vulnerable › Vulnerabilities
CVE-2014-125109: BestWebSoft Portfolio Plugin bws_menu.php bws_add_menu_render cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-26 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in BestWebSoft Portfolio Plugin up to 2.27. It has been declared as problematic. This vulnerability affects the function bws_add_menu_render of the file bws_menu/bws_menu.php. The manipulation of the argument bwsmn_form_email leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 2.28 is able to address this issue. The name of the patch is d2ede580474665af56ff262a05783fbabe4529b8. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-248956.
Affected products
- BestWebSoft Portfolio Plugin: before 2.28 — fixed in 2.28
How to fix
Upgrade to a fixed version: BestWebSoft Portfolio Plugin 2.28. Check the vendor advisory for mitigations.
References
- https://github.com/wp-plugins/portfolio/commit/d2ede580474665af56ff262a05783fbabe4529b8
- https://vuldb.com/?ctiid.248956
- https://vuldb.com/?id.248956
- https://github.com/wp-plugins/portfolio/commit/d2ede580474665af56ff262a05783fbabe4529b8
- https://vuldb.com/?ctiid.248956
- https://vuldb.com/?id.248956
Get alerted when CVE-2014-125109 or the next vulnerability affects your stack