What’s Vulnerable › Vulnerabilities
CVE-2014-125112: Plack::Middleware::Session::Cookie versions through 0.21 for Perl allows remote code execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-26 · updated 2026-06-17
- Weakness: CWE-565
Description
Plack::Middleware::Session::Cookie versions through 0.21 for Perl allows remote code execution. Plack::Middleware::Session::Cookie versions through 0.21 has a security vulnerability where it allows an attacker to execute arbitrary code on the server during deserialization of the cookie data, when there is no secret used to sign the cookie.
Affected products
- MIYAGAWA Plack::Middleware::Session::Cookie: before 0.23 — fixed in 0.23
How to fix
Upgrade to a fixed version: MIYAGAWA Plack::Middleware::Session::Cookie 0.23. Check the vendor advisory for mitigations.
References
- https://gist.github.com/miyagawa/2b8764af908a0dacd43d
- https://metacpan.org/release/MIYAGAWA/Plack-Middleware-Session-0.23-TRIAL/changes
- http://www.openwall.com/lists/oss-security/2026/03/26/2
Get alerted when CVE-2014-125112 or the next vulnerability affects your stack