What’s Vulnerable › Vulnerabilities
CVE-2014-125128
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-08 · updated 2026-06-17
- Weakness: CWE-79
Description
'sanitize-html' prior to version 1.0.3 is vulnerable to Cross-site Scripting (XSS). The function 'naughtyHref' doesn't properly validate the hyperreference (`href`) attribute in anchor tags (`<a>`), allowing bypasses that contain different casings, whitespace characters, or hexadecimal encodings.
Affected products
- apostrophecms sanitize-html: before 1.0.3 — fixed in 1.0.3
How to fix
Upgrade to a fixed version: apostrophecms sanitize-html 1.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/Checkmarx/Vulnerabilities-Proofs-of-Concept/tree/main/2014/CVE-2014-125128
- https://github.com/apostrophecms/sanitize-html/commit/423b90e06e1e85245eccedaabeb3a82840c6cd86
- https://github.com/apostrophecms/sanitize-html/commit/889d4ec968e175f1905b2eb9d33f1fa89217cb02
- https://github.com/apostrophecms/sanitize-html/issues/1
Get alerted when CVE-2014-125128 or the next vulnerability affects your stack