What’s Vulnerable › Vulnerabilities
CVE-2014-125132: Blogroll Fun WordPress Plugin < 0.8.5 Reflected XSS via blogroll.php
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-28
- Weakness: CWE-79
Description
Blogroll Fun plugin for WordPress before 0.8.5 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject scripts through the 'k' parameter in blogroll.php. Attackers can craft GET requests to /wp-content/plugins/blogroll-fun/blogroll.php with malicious 'k' values that are echoed unsanitized, executing JavaScript in victims' browsers. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Affected products
- Jason Newman Blogroll Fun: before 0.8.5 — fixed in 0.8.5
How to fix
Upgrade to a fixed version: Jason Newman Blogroll Fun 0.8.5. Check the vendor advisory for mitigations.
References
- https://codevigilant.com/disclosure/wp-plugin-blogroll-fun-a3-cross-site-scripting-xss/
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/wp-blogroll-fun-xss.yaml
- https://wordpress.org/plugins/blogroll-fun/
- https://www.acunetix.com/vulnerabilities/web/wordpress-plugin-blogroll-fun-show-last-post-and-last-update-time-cross-site-scripting-0-8-4/
- https://www.vulncheck.com/advisories/blogroll-fun-wordpress-plugin-0.8.5-reflected-xss-via-blogroll-php
Get alerted when CVE-2014-125132 or the next vulnerability affects your stack