What’s Vulnerable › Vulnerabilities
CVE-2014-125134: ChurcHope WordPress Theme < 2.2 Path Traversal via downloadlink.php
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-20 · updated 2026-10-23
- Weakness: CWE-22
Description
ChurcHope theme for WordPress before 2.2 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files through the 'file' parameter of /wp-content/themes/churchope/lib/downloadlink.php. Attackers can supply directory traversal sequences to read sensitive files like wp-config.php or /etc/passwd, exposing database credentials. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-18.
Affected products
- ChurcHope: before 2.2 — fixed in 2.2
How to fix
Upgrade to a fixed version: ChurcHope 2.2. Check the vendor advisory for mitigations.
References
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/churchope-lfi.yaml
- https://packetstorm.news/files/id/129706/
- https://web.archive.org/web/20220629224817/https://www.cloudways.com/en/best-wordpress-themes/nonprofit/church
- https://wpscan.com/vulnerability/3c5833bd-1fe0-4eba-97aa-7d3a0c8fda15
- https://www.vulncheck.com/advisories/churchope-wordpress-theme-2.2-path-traversal-via-downloadlink-php
Get alerted when CVE-2014-125134 or the next vulnerability affects your stack