What’s Vulnerable › Vulnerabilities
CVE-2014-1427: MAAS API vulnerable to CSRF attack
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the REST API of Ubuntu MAAS allows an attacker to cause a logged-in user to execute commands via cross-site scripting. This issue affects MAAS versions prior to 1.9.2.
Affected products
- Canonical Metal As A Service: before 1.9.2 — fixed in 1.9.2
How to fix
Upgrade to a fixed version: Canonical Metal As A Service 1.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2014-1427 or the next vulnerability affects your stack