What’s Vulnerable › Vulnerabilities
CVE-2014-1478
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-02-06 · updated 2026-06-17
- Weakness: CWE-787
Description
Multiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 27.0 and SeaMonkey before 2.24 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via vectors related to the MPostWriteBarrier class in js/src/jit/MIR.h and stack alignment in js/src/jit/AsmJS.cpp in OdinMonkey, and unknown other vectors.
Affected products
- Canonical Ubuntu Linux: 12.04, 12.10, 13.10
- Mozilla Firefox: before 27.0 — fixed in 27.0
- Mozilla Seamonkey: before 2.24 — fixed in 2.24
- Opensuse: 11.4, 12.3, 13.1
- Oracle Corporation Solaris Operating System: 11.3
How to fix
Upgrade to a fixed version: Mozilla Firefox 27.0; Mozilla Seamonkey 2.24. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2014-02/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2014-02/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00017.html
- http://osvdb.org/102865
- http://secunia.com/advisories/56706
- http://secunia.com/advisories/56767
- http://secunia.com/advisories/56787
- http://secunia.com/advisories/56888
- http://secunia.com/advisories/56922
- http://www.mozilla.org/security/announce/2014/mfsa2014-01.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securityfocus.com/bid/65324
Get alerted when CVE-2014-1478 or the next vulnerability affects your stack