What’s Vulnerable › Vulnerabilities
CVE-2014-1485
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-02-06 · updated 2026-06-17
Description
The Content Security Policy (CSP) implementation in Mozilla Firefox before 27.0 and SeaMonkey before 2.24 operates on XSLT stylesheets according to style-src directives instead of script-src directives, which might allow remote attackers to execute arbitrary XSLT code by leveraging insufficient style-src restrictions.
Affected products
- Canonical Ubuntu Linux: 12.04, 12.10, 13.10
- Mozilla Firefox: before 27.0 — fixed in 27.0
- Mozilla Seamonkey: before 2.24 — fixed in 2.24
- Opensuse: 11.4, 12.3, 13.1
- Oracle Corporation Solaris Operating System: 11.3
- SUSE Linux Enterprise Server 15 SP1: 11-sp3
- SUSE Linux Enterprise Server: 11-sp3
- SUSE Linux Enterprise Software Development Kit: 11-sp3
How to fix
Upgrade to a fixed version: Mozilla Firefox 27.0; Mozilla Seamonkey 2.24. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2014-02/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2014-02/msg00010.html
- http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00017.html
- http://osvdb.org/102871
- http://secunia.com/advisories/56706
- http://secunia.com/advisories/56767
- http://secunia.com/advisories/56787
- http://secunia.com/advisories/56888
- http://www.mozilla.org/security/announce/2014/mfsa2014-07.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securityfocus.com/bid/65322
- http://www.securitytracker.com/id/1029717
Get alerted when CVE-2014-1485 or the next vulnerability affects your stack