What’s Vulnerable › Vulnerabilities
CVE-2014-1508
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2014-03-19 · updated 2026-06-17
- Weakness: CWE-125
Description
The libxul.so!gfxContext::Polygon function in Mozilla Firefox before 28.0, Firefox ESR 24.x before 24.4, Thunderbird before 24.4, and SeaMonkey before 2.25 allows remote attackers to obtain sensitive information from process memory, cause a denial of service (out-of-bounds read and application crash), or possibly bypass the Same Origin Policy via vectors involving MathML polygon rendering.
Affected products
- Canonical Ubuntu Linux: 12.04, 12.10, 13.10
- Debian Linux: 7.0, 8.0
- Mozilla Firefox: before 28.0; from 24.0 before 24.4 — fixed in 24.4, 28.0
- Mozilla Seamonkey: before 2.25 — fixed in 2.25
- Mozilla Thunderbird: before 24.4 — fixed in 24.4
- Opensuse: 11.4, 12.3, 13.1
- RedHat Enterprise Linux Desktop: 5.0, 6.0
- RedHat Enterprise Linux Eus: 6.5
- RedHat Enterprise Linux Server: 5.0, 6.0
- RedHat Enterprise Linux Server Aus: 6.5
- RedHat Enterprise Linux Server Eus: 6.5
- RedHat Enterprise Linux Server Tus: 6.5
- RedHat Enterprise Linux Workstation: 5.0, 6.0
- Suse Linux Enterprise Desktop: 11-sp3
- SUSE Linux Enterprise: 11-sp3
- Suse Linux Enterprise Software Development Kit: 11.0-sp3
How to fix
Upgrade to a fixed version: Mozilla Firefox 24.4, 28.0; Mozilla Seamonkey 2.25; Mozilla Thunderbird 24.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00017.html
- http://lists.opensuse.org/opensuse-security-announce/2014-03/msg00022.html
- http://lists.opensuse.org/opensuse-security-announce/2014-04/msg00016.html
- http://rhn.redhat.com/errata/RHSA-2014-0310.html
- http://rhn.redhat.com/errata/RHSA-2014-0316.html
- http://www.debian.org/security/2014/dsa-2881
- http://www.debian.org/security/2014/dsa-2911
- http://www.mozilla.org/security/announce/2014/mfsa2014-26.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- http://www.securityfocus.com/bid/66426
- http://www.ubuntu.com/usn/USN-2151-1
Get alerted when CVE-2014-1508 or the next vulnerability affects your stack