What’s Vulnerable › Vulnerabilities

CVE-2014-1509

Description

Buffer overflow in the _cairo_truetype_index_to_ucs4 function in cairo, as used in Mozilla Firefox before 28.0, Firefox ESR 24.x before 24.4, Thunderbird before 24.4, and SeaMonkey before 2.25, allows remote attackers to execute arbitrary code via a crafted extension that renders fonts in a PDF document.

Affected products

How to fix

Upgrade to a fixed version: Mozilla Firefox 24.4, 28.0; Mozilla Seamonkey 2.25; Mozilla Thunderbird 24.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-1509 or the next vulnerability affects your stack