What’s Vulnerable › Vulnerabilities

CVE-2014-1514

Description

vmtypedarrayobject.cpp in Mozilla Firefox before 28.0, Firefox ESR 24.x before 24.4, Thunderbird before 24.4, and SeaMonkey before 2.25 does not validate the length of the destination array before a copy operation, which allows remote attackers to execute arbitrary code or cause a denial of service (out-of-bounds write and application crash) by triggering incorrect use of the TypedArrayObject class.

Affected products

How to fix

Upgrade to a fixed version: Mozilla Firefox 24.4, 28.0; Mozilla Seamonkey 2.25; Mozilla Thunderbird 24.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-1514 or the next vulnerability affects your stack