What’s Vulnerable › Vulnerabilities
CVE-2014-1523
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-04-30 · updated 2026-06-17
- Weakness: CWE-787
Description
Heap-based buffer overflow in the read_u32 function in Mozilla Firefox before 29.0, Firefox ESR 24.x before 24.5, Thunderbird before 24.5, and SeaMonkey before 2.26 allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted JPEG image.
Affected products
- Canonical Ubuntu Linux: 12.04, 12.10, 13.10, 14.04
- Debian Linux: 7.0, 8.0
- Fedoraproject Fedora: 19, 20
- Mozilla Firefox: before 29.0; from 24.0 before 24.5 — fixed in 24.5, 29.0
- Mozilla Seamonkey: before 2.26 — fixed in 2.26
- Mozilla Thunderbird: before 24.5 — fixed in 24.5
- Opensuse: 11.4, 12.3, 13.1
- RedHat Enterprise Linux Desktop: 5.0, 6.0
- RedHat Enterprise Linux Eus: 6.5
- RedHat Enterprise Linux Server: 5.0, 6.0
- RedHat Enterprise Linux Server Aus: 6.5
- RedHat Enterprise Linux Server Eus: 6.5
- RedHat Enterprise Linux Server Tus: 6.5
- RedHat Enterprise Linux Workstation: 5.0, 6.0
- SUSE Linux Enterprise: 10-sp4, 11-sp1
How to fix
Upgrade to a fixed version: Mozilla Firefox 24.5, 29.0; Mozilla Seamonkey 2.26; Mozilla Thunderbird 24.5. Check the vendor advisory for mitigations.
References
- http://lists.fedoraproject.org/pipermail/package-announce/2014-May/132332.html
- http://lists.fedoraproject.org/pipermail/package-announce/2014-May/132437.html
- http://lists.opensuse.org/opensuse-security-announce/2014-05/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2014-05/msg00015.html
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00010.html
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00013.html
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00033.html
- http://lists.opensuse.org/opensuse-updates/2014-05/msg00040.html
- http://rhn.redhat.com/errata/RHSA-2014-0448.html
- http://rhn.redhat.com/errata/RHSA-2014-0449.html
- http://www.debian.org/security/2014/dsa-2918
- http://www.debian.org/security/2014/dsa-2924
Get alerted when CVE-2014-1523 or the next vulnerability affects your stack