What’s Vulnerable › Vulnerabilities
CVE-2014-1665
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in ownCloud before 6.0.1 allows remote authenticated users to inject arbitrary web script or HTML via the filename of an uploaded file.
Affected products
- Owncloud: before 6.0.1 — fixed in 6.0.1
How to fix
Upgrade to a fixed version: Owncloud 6.0.1. Check the vendor advisory for mitigations.
References
- http://blog.noobroot.com/2014/02/owncloud-600a-when-xss-vulnerability.html
- http://www.securityfocus.com/bid/65457
- https://exchange.xforce.ibmcloud.com/vulnerabilities/91012
- https://packetstormsecurity.com/files/125086
- https://www.exploit-db.com/exploits/31427/
- http://blog.noobroot.com/2014/02/owncloud-600a-when-xss-vulnerability.html
- http://www.securityfocus.com/bid/65457
- https://exchange.xforce.ibmcloud.com/vulnerabilities/91012
- https://packetstormsecurity.com/files/125086
- https://www.exploit-db.com/exploits/31427/
Get alerted when CVE-2014-1665 or the next vulnerability affects your stack