What’s Vulnerable › Vulnerabilities

CVE-2014-1737

Description

The raw_cmd_copyin function in drivers/block/floppy.c in the Linux kernel through 3.14.3 does not properly handle error conditions during processing of an FDRAWCMD ioctl call, which allows local users to trigger kfree operations and gain privileges by leveraging write access to a /dev/fd device.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.10.40, 3.12.20, 3.14.4, 3.2.59. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-1737 or the next vulnerability affects your stack