What’s Vulnerable › Vulnerabilities
CVE-2014-1846
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-27 · updated 2026-06-17
- Weakness: CWE-264
Description
Enlightenment before 0.17.6 might allow local users to gain privileges via vectors involving the gdb method.
Affected products
- Enlightenment: before 0.17.6 — fixed in 0.17.6
How to fix
Upgrade to a fixed version: Enlightenment 0.17.6. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/02/03/19
- https://bugzilla.redhat.com/show_bug.cgi?id=1059410
- https://exchange.xforce.ibmcloud.com/vulnerabilities/91215
- https://git.enlightenment.org/core/enlightenment.git/commit/?id=bb4a21e98656fe2c7d98ba2163e6defe9a630e2b
- http://www.openwall.com/lists/oss-security/2014/02/03/19
- https://bugzilla.redhat.com/show_bug.cgi?id=1059410
- https://exchange.xforce.ibmcloud.com/vulnerabilities/91215
- https://git.enlightenment.org/core/enlightenment.git/commit/?id=bb4a21e98656fe2c7d98ba2163e6defe9a630e2b
Get alerted when CVE-2014-1846 or the next vulnerability affects your stack