What’s Vulnerable › Vulnerabilities
CVE-2014-1867
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-13 · updated 2026-06-17
- Weakness: CWE-287
Description
suPHP before 0.7.2 source-highlighting feature allows security bypass which could lead to arbitrary code execution
Affected products
- suphp: before 0.7.2 — fixed in 0.7.2
How to fix
Upgrade to a fixed version: suphp 0.7.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2014/02/10/1
- http://www.securityfocus.com/bid/65212
- https://exchange.xforce.ibmcloud.com/vulnerabilities/91315
- https://security-tracker.debian.org/tracker/CVE-2014-1867
- http://www.openwall.com/lists/oss-security/2014/02/10/1
- http://www.securityfocus.com/bid/65212
- https://exchange.xforce.ibmcloud.com/vulnerabilities/91315
- https://security-tracker.debian.org/tracker/CVE-2014-1867
Get alerted when CVE-2014-1867 or the next vulnerability affects your stack