What’s Vulnerable › Vulnerabilities
CVE-2014-1874
- Severity: medium (CVSS 4.9 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2014-02-28 · updated 2026-06-17
- Weakness: CWE-20
Description
The security_context_to_sid_core function in security/selinux/ss/services.c in the Linux kernel before 3.13.4 allows local users to cause a denial of service (system crash) by leveraging the CAP_MAC_ADMIN capability to set a zero-length security context.
Affected products
- Canonical Ubuntu Linux: 10.04, 12.04, 12.10, 13.10
- Linux kernel: before 3.13.4 — fixed in 3.13.4
- SUSE Linux Enterprise Server: 10-sp4
How to fix
Upgrade to a fixed version: Linux kernel 3.13.4. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=2172fa709ab32ca60e86179dc67d0857be8e2c98
- http://linux.oracle.com/errata/ELSA-2014-0771.html
- http://linux.oracle.com/errata/ELSA-2014-3043.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00020.html
- http://secunia.com/advisories/59262
- http://secunia.com/advisories/59309
- http://secunia.com/advisories/59406
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.13.4
- http://www.openwall.com/lists/oss-security/2014/02/07/2
- http://www.securityfocus.com/bid/65459
- http://www.ubuntu.com/usn/USN-2128-1
- http://www.ubuntu.com/usn/USN-2129-1
Get alerted when CVE-2014-1874 or the next vulnerability affects your stack