What’s Vulnerable › Vulnerabilities

CVE-2014-1904

Description

Cross-site scripting (XSS) vulnerability in web/servlet/tags/form/FormTag.java in Spring MVC in Spring Framework 3.0.0 before 3.2.8 and 4.0.0 before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the requested URI in a default action.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 3.2.8, 4.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-1904 or the next vulnerability affects your stack