What’s Vulnerable › Vulnerabilities
CVE-2014-1958
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-02-06 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer overflow in the DecodePSDPixels function in coders/psd.c in ImageMagick before 6.8.8-5 might allow remote attackers to execute arbitrary code via a crafted PSD image, involving the L%06ld string, a different vulnerability than CVE-2014-2030.
Affected products
- Canonical Ubuntu Linux: 12.04, 12.10, 13.10
- ImageMagick: before 6.8.8-5 — fixed in 6.8.8-5
- Opensuse: 11.4, 12.3, 13.1
How to fix
Upgrade to a fixed version: ImageMagick 6.8.8-5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00032.html
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00039.html
- http://trac.imagemagick.org/changeset/14801
- http://ubuntu.com/usn/usn-2132-1
- http://www.openwall.com/lists/oss-security/2014/02/13/2
- http://www.openwall.com/lists/oss-security/2014/02/13/5
- https://www.openwall.com/lists/oss-security/2014/02/19/13
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00032.html
- http://lists.opensuse.org/opensuse-updates/2014-03/msg00039.html
- http://trac.imagemagick.org/changeset/14801
- http://ubuntu.com/usn/usn-2132-1
- http://www.openwall.com/lists/oss-security/2014/02/13/2
Get alerted when CVE-2014-1958 or the next vulnerability affects your stack