What’s Vulnerable › Vulnerabilities

CVE-2014-2016

Description

Multiple cross-site scripting (XSS) vulnerabilities in OXID eShop Professional and Community Edition 4.6.8 and earlier, 4.7.x before 4.7.11, and 4.8.x before 4.8.4, and Enterprise Edition 4.6.8 and earlier, 5.0.x before 5.0.11 and 5.1.x before 5.1.4 allow remote attackers to inject arbitrary web script or HTML via the searchtag parameter to the getTag function in (1) application/controllers/details.php or (2) application/controllers/tag.php.

Affected products

How to fix

Upgrade to a fixed version: OXID-eSales Eshop 4.7.11, 4.8.4, 5.0.11, 5.1.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-2016 or the next vulnerability affects your stack