What’s Vulnerable › Vulnerabilities

CVE-2014-2031

Description

Deadwood before 2.3.09, 3.x before 3.2.05, and as used in MaraDNS before 1.4.14 and 2.x before 2.0.09, allow remote attackers to cause a denial of service (out-of-bounds read and crash) by leveraging permission to perform recursive queries against Deadwood, related to a logic error.

Affected products

How to fix

Upgrade to a fixed version: Deadwood Project Deadwood 2.3.09, 3.2.05; Maradns Project Maradns 1.4.14, 2.0.09. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2014-2031 or the next vulnerability affects your stack